Results 1 to 8 of 8

Thread: WTB 20v valve springs

  1. #1
    Join Date
    Jun 2010
    Location
    Vancouver BC
    Posts
    80

    WTB 20v valve springs

    Looking to purchase a few 4ag 20v valve springs. Let me know what u have. Thanks in advance! Have a ticking sound coming from the middle of the engine and pretty sure it's a valve spring issue.

  2. #2
    Join Date
    Mar 2010
    Location
    North Van
    Posts
    265
    yo got ur txt. My cell is dead. I cant find my charger. I might have my stock springs. I'll check my parts box. I hope i didnt throw them out.

  3. #3
    Join Date
    Jul 2008
    Location
    Vancouver BC
    Posts
    2,984
    lol forgot you had some too, i asked tak for him also though if you lost it

  4. #4
    Join Date
    Jun 2010
    Location
    Vancouver BC
    Posts
    80
    Thanks u guys!! Let me know if any of u have any luck. Cars up on jack stands and it's confirmed a valve spring that caused the ticking sound.

  5. #5
    Join Date
    Mar 2010
    Location
    North Van
    Posts
    265
    no dice. i couldn't find them. I think i did throw them out. eh

  6. #6
    Join Date
    Jun 2010
    Location
    Vancouver BC
    Posts
    80
    Hey Oz, no probs, ahh well.. Now to hope that Tak has a set.

  7. #7
    Join Date
    Jul 2008
    Location
    Vancouver BC
    Posts
    2,984
    yeah 5 bucks each, hes got his hands full at the shop but you can pick it up off me. i should have them by monday night, how many did you want?

  8. #8
    Join Date
    Jun 2010
    Location
    Vancouver BC
    Posts
    80
    Sweet! msged ya!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •