Results 1 to 18 of 18

Thread: Reverse lights still won't work need help thanks

  1. #1
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9

    Icon4 Reverse lights still won't work need help thanks

    So I just changed out the old backup switch also fuses on the kicker panel, and had to splice new socket holders they where really nasty. Still no power when I go into reverse but my tail lights work just no reverse light. Please leave me some pics or anything thanks!!!

  2. #2
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    Any one really could use some help...��

  3. #3
    Join Date
    Jun 2008
    Location
    v isl
    Posts
    4,649
    Is the switch on the gearbox working? Wire fell off?

  4. #4
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    Yea it's new & yes the wires are on

  5. #5
    Join Date
    Aug 2010
    Location
    Toronto
    Posts
    159
    Any corrosion on the connectors/terminals?
    I had a problem like this before, sandpaper was the fix.
    85 Coupe
    BUILD LOG

  6. #6
    Join Date
    Nov 2012
    Location
    Brampton, Ontario
    Posts
    1,488
    Do you have a multimeter. It takes some real ingenuity to diagnose electrical problems without a multimeter.

    Also, I presume this is an Corolla? AE86 GTS?

    Click image for larger version. 

Name:	revlight.JPG 
Views:	24 
Size:	53.9 KB 
ID:	14463

  7. #7
    Join Date
    Jun 2008
    Location
    v isl
    Posts
    4,649
    I would guess that somewhere between the back up lights and the switch itself the connection has been broken, most likely worn through wire rubbing on something?

    That or the grounds from the bulbs to chassis? Does the fuse blow?

  8. #8
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    The back up switch is new & I sanded the connectors still the same no power.

  9. #9
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    Grounds are fine I think, I still have to figure out why is there no power.

  10. #10
    Join Date
    Jun 2004
    Location
    Victoria, BC
    Posts
    5,640
    So back to Sparkies question..

    Do you have a multimeter.

    Brett
    '87 AE86 - GTSR5 - Daily Driver
    '72 RA21 Celica - 'Ill build it one day'
    '73 RN27 Hilux - Restomod in progress
    '80 MX32 Cressida - Next in the project queue
    '91 SV25 Camry All-Trac - Winter DD

  11. #11
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    Yea I do

  12. #12
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    It's an sr5 model 5 speed

  13. #13
    Join Date
    Jun 2012
    Location
    Nanaimo, BC
    Posts
    636
    Is it a new switch or a used replacement. I had one that wasn't working and I pulled the switch from the trans. Then I pressed the little switch a few times and some gear oil squirted out then it worked fine afterwards

  14. #14
    Join Date
    Nov 2012
    Location
    Brampton, Ontario
    Posts
    1,488
    Quote Originally Posted by Dorizilla819 View Post
    Yea I do
    can you measure 12V at the connector going to the switch in the transmission? The ignition switch must be in the run position.

  15. #15
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    It's a new switch I'll try this tomorrow thanks

  16. #16
    Join Date
    Sep 2004
    Location
    Anus Victoria
    Posts
    5,333
    lol check the bulbs?
    SpeedHero

    Spirit of the Street, King of Sport

  17. #17
    Join Date
    Jul 2015
    Location
    Honolulu Hawaii
    Posts
    9
    The bulbs are new

  18. #18
    Join Date
    Oct 2014
    Location
    Victoria, BC
    Posts
    24
    Do the part numbers on the reverse switch you installed match the oem part numbers? I installed the wrong backup switch in my e34 and was stumped for months till I read the package and compared it to a parts catalog.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •